Delayed response completion on Claude.ai

Incident Report for Claude

Resolved

As of 13:02 UTC / 06:02 PT this incident has been mitigated.
Posted Mar 22, 2026 - 13:13 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 22, 2026 - 12:34 UTC

Investigating

Since approximately 20:00 UTC / 13:00 PT on Friday, March 20, Claude.ai responses may appear to "hang" for around 5 seconds after the text has finished streaming before the message completes. The Anthropic API is not affected.
Posted Mar 22, 2026 - 11:14 UTC
This incident affected: claude.ai.