Issues with Code Execution Tool

Incident Report for Claude

Postmortem

In the process of rolling out a feature, we made a code change that went out at approximately 2026/02/14 06:30 UTC that resulted in errors for API requests using the Code Execution tool. This introduced an incompatibility between two services when one was rolled out but not the other. We have since identified the issue, have resolved it, and will be putting in automatic alerts to auto-detect these incompatibilities going forawrd.

Posted Feb 14, 2026 - 16:48 UTC

Resolved

We have deployed a fix for Code Execution tool on the API.
Posted Feb 14, 2026 - 16:39 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 14, 2026 - 16:38 UTC

Monitoring

We have identified the issue with the Code Execution tool and have rolled out a fix. We're monitoring to confirm resolution.
Posted Feb 14, 2026 - 16:27 UTC

Investigating

We're currently investigating an issue where API requests using the Code Execution Tool are erroring for users.
Posted Feb 14, 2026 - 16:13 UTC