Claude Code showing "JSON Parse error: Unexpected EOF" and writing excessive files on Windows

Incident Report for Claude

Update

We are continuing to work on deploying a hotfix for this issue.
Posted Feb 26, 2026 - 21:06 UTC

Identified

We have identified a bug where Windows users are experiencing significant write contention for the .claude.json global config file, starting with Claude Code 2.1.59. We are working on a hotfix.
Posted Feb 26, 2026 - 19:57 UTC
This incident affects: Claude Code.